PHP5 结束了

PHP5 结束了

如果你还在使用 PHP5,现在是时候升级到新版本的 PHP 了。

PHP,开源脚本语言,世界上近 80% 的站点使用它。据 W3Techs 调查,互联网上约 61% 的站点仍然在使用 PHP5,PHP5 首次发布于 14 年前。

2018 年 12 月 31 日,官方将停止 PHP 5 的安全支持。所以无论从安全或性能上考虑都是时候升级 PHP 5 到新版本了。

Drupal 和 PHP 5

Drupal 8

Drupal 8 会支持 PHP 5 到 2019 年 3 月 6 日。如果可能的话我们推荐至少升级到 PHP 7.1,但最好是 PHP 7.2。Drupal 8.5(2018 年 3 月发布) 支持 PHP 7.2,Drupal 8.7 (将于 2019 年 5 月发布)将支持 PHP 7.3,近期我们也可能使 Drupal 8.6 支持 PHP 7.3。

Drupal 7

Drupal 7 会支持 PHP 5 的老版本到 2018 年 12 月 31 日。但只要有第三方组织提供可靠的 PHP 5 安全扩展,那么我们将继续支持 PHP 5.6。

我们刚发布的 Drupal 7.61 现在支持 PHP 7.2。Drupal 7 之后也会支持 PHP 7.3,但时间不确定。

谢谢

感谢 PHP 社区维护了 PHP 5 14 年。但不会永远持续下去,是时候升级 PHP 5 到新版本了,这样我们可以快速创新。

我也想感谢那些为 Drupal 8 和 Drupal 7 做出贡献,使其兼容最新 PHP 版本的 Drupal 社区人员,

编辑于 2018-11-27

文章被以下专栏收录